Windows System Image Backup - Win 10

Da qualche anno a questa parte, in particolare da quando uso dischi ssd (coi quali ho avuto qualche piccolo inconveniente nel recente passato), su base regolare ma non troppo, effettuo dei backup del sistema operativo col tool di windows "Windows System Image Backup".

Ho iniziato facendoli su un disco usb esterno, per poi passare a effettuarli su un nas Synology. Ho sempre e solo effettuato il backup del disco principale su cui sta il sistema operativo e i programmi "importanti": giochi e multimedia stanno altrove e non necessitano di backup (almeno, non di questo tipo).

Tutto ha funzionato bene fino a quando, circa un anno fa, Windows 8.1 ha iniziato a presentarmi questa schermata, senza all'apparenza che io avessi fatto alcuna modifica riconducibile a System Image Backup.

backup_win

Non mi permetteva cioè di escludere il disco E: (GIOCHI) da quelli che si voglino salvare, considerandolo di sistema. Visto che il backup lo faccio una volta ogni tanto e non avevo voglia di perdere troppo tempo, mi sono limitato a una breve e inconcludente indagine, rinviando il problema al futuro.

Ora, dopo l'aggiornamento a Windows 10, ho riprovato a effettuare la medesima operazione pensando che il problema fosse risolto e invece la schermata che mi si è presentata è stata la stessa che si vede qui sopra.

Questa volta ho deciso di approfondire più seriamente e la soluzione al problema si può leggere in questo link

https://social.technet.microsoft.com/Forums/Sharepoint/en-US/b8e726fc-9f95-4416-9212-7e24b01a111c/windows-7-backup-system-image-includes-non-system-disk?forum=w7itproinstall

 

Riassumendo (come fa qualcuno all'interno del post), il problema può avere queste 3 cause:
(C: è il disco di sistema di cui mi va bene fare il backup, E: è il disco che non vorrei salvare ma di cui non riesco a togliere la spunta)

  1. O il disco/partizione E: è marcato come "Active"  (o system). Si può controllare dal Computer Management/Disk Management (Control Panel\All Control Panel Items\Administrative Tools)
  2. O abbiamo spostato le cartelle di sistema di qualche utente (My Documents, Pictures etc) in E:
  3. O qualche servizio installato ha lasciato delle tracce nel registro che puntano a E:

Le prime 2 opzioni sono facilmente verificabili e non era questo il mio caso.

Per verificare l'opzione 3 invece serve un po' di pazienza. Prima di tutto si può aprire l'elenco dei servizi (services.msc) e guardare quelli "sospetti": se la riga "Path to executable" punta a E: si deve fermare e poi eliminare il programma che ha creato il servizio.
Visto che sono un po' pigro e di scorrere a mano tutti i servizi non avevo voglia, ho preferito lanciare da Windows Power Shell il comando

che elenca il pathname di ciascun servizio.
Questo però può non bastare,  perchè spesso l'eliminazione del servizio lascia una riga nel registro con un riferimento a un file mancante. Anche in questo caso il "System Image Backup" penserà che il disco referenziato dal servizio appena eliminato e fermato (E: nel mio caso) sia di sistema.
Come spiegato nel post di cui sopra, ho scaricato e lanciato l'utility di Sysinternals "autoruns"
https://technet.microsoft.com/en-us/sysinternals/bb963902.aspx
Nel tab "Everything" ho controllato uno ad uno che nella colonna "Image Path" non ci fosse alcun riferimento al disco E:, anche in caso di "File not found". Trovando qualcosa è sufficende eliminare la entry.
Alternativamente è possibile anche andare a mano a spulciare nel registro andando a cercare nella chiave "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services" la stringa "E:"
Viene anche suggerito, sempre come alternativa, di lanciare CCleaner e di eliminare quei servizi che fanno riferimento al drive E:

Nel post di Technet qualcuno ha trovato che il "colpevole" era un servizio di update automatico del gioco "Dragon Age Origin": nel mio caso era un qualcosa di simile, ovvero il servizio GOG Galaxy (una specie di Steam; Ok, non è per niente come Steam, che i polacchi mi perdonino, ma è giusto per capirsi) che avevo, correttamente dal mio punto di vista, installato in E:.

Dopo aver spento il servizio tra i services.msc,

GalaxyClientService                                    GalaxyClientService                                                   Stopped "E:\GOG-GalaxyClient\GalaxyClientService.exe"

aver eliminato il programma da "Control Panel\All Control Panel Items\Programs and Features"  e aver eliminato l'Autorun Entry usando "Autoruns" di sysinternals, il backup mi ha permesso di togliere la spunta dal disco E: e tutto è tornato "normale"

backup_win_2

P.S: Ovviamente è folle considerare un disco di "Sistema" solo perchè un servizio in autorun ci fa riferimento...

P.P.S: La soluzione alternativa sarebbe stata quella di mettere "offline" l'intero disco: si agisce sempre da Computer Management/Disk Management (Control Panel\All Control Panel Items\Administrative Tools), si clicca per esempio su "Disk 1", tasto destro e poi "offline".

Print Friendly, PDF & Email